Ciscoルーターの基本設定|設定・確認コマンドから保存方法まで

ネットワーク

本ページではCiscoルーターの基本設定の手順とコマンドをナレッジとして記します。

基本設定はユーザーモードから解説していきますので、ユーザーモードまでのCiscoルーターのケーブリングと初期起動は以下の1をご参照ください。

  1. Ciscoルーターへコンソール接続するためのケーブリングから初期起動まで 
  2. Ciscoルーターの基本設定|設定・確認コマンドから保存方法まで ←現在
  3. CiscoルーターへTelnet接続するまで

Ciscoルーターは全て1812Jを使っています。

PCはMacBookです。

 

以下はCiscoルーターの基本設定の項目です。順を追って見ていきます。

  • ホスト名の設定
  • IPアドレスとサブネットマスクの設定
  • インターフェイスの有効化
  • パスワードの設定
  • ルーティング(準備中)
  • 設定の保存

 

ネットワークの知識が全くない方は基礎の基礎を身につけられる「1週間で CCNAの基礎が学べる本」の一読をおすすめします。

 

Ciscoルーターの基本設定の前にIOSのモードについて確認していきます。そんなの知っているよという方は目次からジャンプして、ホスト名の設定から読んでみてください。

 

 

CiscoルーターIOSモード

IOSはCiscoのルーターで使用しているOSで機能や用途に応じていろいろなモードに切り替えて実行します。

IOSモードには以下のものがあります。

  • ユーザーモード
  • 特権モード
  • グローバルコンフィグレーションモード
  • インターフェースコンフィグレーションモード
  • ラインコンフィグレーションモード
  • その他のコンフィグレーションモード

その他のモードは多数あるのですが、基本設定では出番がありませんので、また別の機会で。

ホスト名の設定はグローバルコンフィグレーションモードで行いますのでそこまでの過程を見ていきましょう。

 

ユーザーモード(ユーザーEXECモード)

ユーザーモードは一部の情報を見たり、一部のコマンドの利用ができるモードです。

Ciscoルーターの初期起動が完了すると以下のRouterというデバイスのホスト名と>のプロンプトが表示されます。

Router> ←ユーザーモード

Routerはデフォルトのホスト名になり、初期設定のホスト名の設定はこのRouterを別のホスト名に変更する設定です。

 

特権モード(特権EXECモード)

特権モードは全ての設定情報を見ることができるモードです。

ユーザーモードで以下のenableコマンドを入力してEnterを押すと切り替わります。

Router>enable
Router# ←特権モード

 

ユーザーモードに戻るときはdisableコマンドで戻ります。

Router#disable
Router>

 

グローバルコンフィグレーションモード

グローバルコンフィグレーションモードはデバイスの全てに関わる設定を行うことができます。

特権モードでconfigure terminalとコマンドを入力しEnter。

すると以下の様にグローバルコンフィグレーションモードに切り替わります。

Router#configure terminal ←コマンド入力
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# ←グローバルコンフィグレーションモード

 

特権モードに戻るにはexitコマンドを打ちます。

Router(config)#exit
Router#

 

インターフェースコンフィグレーションモード

インターフェースコンフィグレーションモードはインターフェースの設定するモードとなります。

以下はFastEhernet1のインターフェースに移行する場合のコマンドとなります。

Router(config)#interface FastEthernet1 ←コマンド入力
Router(config-if)#

 

ラインコンフィグレーションモード

ラインコンフィグレーションモードはコンソール、AUX、VTYポートにに対して設定をするモードとなります。

以下はコンソールポートを設定するモードに移行するコマンドになります。

Router(config)#line console 0 ←コマンド入力
Router(config-line)#

 

以上までがでCiscoルーターのISOモードの説明になります。

ISOモードについてもっとしっかり学びたい方は「徹底攻略 Cisco CCENT/CCNA Routing & Switching 教科書」がおすすめです。

次からはいよいよCiscoルーターの基本設定について見ていきます。

ホスト名の設定

ではホスト名から設定をしていきましょう。

繰り返しになりますがホスト名の設定はグローバルコンフィグレーションモードで実行します。

グローバルコンフィグレーションモードで以下のコマンドでホスト名が変更できます。「R-temlog」のホスト名は自由に変えてください。

Router(config)#host R-temlog
R-temlog(config)# ←ホスト名がR-temlogに変更された

 

ホスト名を元のRouterに戻したいときは以下のコマンドで戻ります。

R-temlog(config)#no hostname
Router(config)#

 

ではホスト名が変更されたか確認してみましょう。

変更の確認は特権モードに戻って、show running-configコマンドで確かめます。

R-temlog(config)#exit
R-temlog#show running-config
Building configuration...

Current configuration : 1225 bytes
!
! Last configuration change at 13:28:35 UTC Fri Aug 9 2019
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R-temlog ←ホスト名が変更されているのが確認できます。
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip source-route
          
R-temlog#

 

IPアドレスとサブネットマスクの設定

FastEthernet1にIPアドレスとサブネットマスクを設定していきます。

この設定は各インターフェースに異なるネットワーク上のIPを割り当てる必要があるため行います。

まずは特権モードでshow ip interface briefコマンドを打ち各インターフェースのリンク状況を確認していきます。

R-temlog#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
BRI0                       unassigned      YES unset  administratively down down    
BRI0:1                     unassigned      YES unset  administratively down down    
BRI0:2                     unassigned      YES unset  administratively down down    
FastEthernet0              unassigned      YES unset  administratively down down    
FastEthernet1              unassigned      YES unset  administratively down down ←インターフェースが閉じていて、shutdownが設定されている  
FastEthernet2              unassigned      YES unset  up                    down    
FastEthernet3              unassigned      YES unset  up                    down    
FastEthernet4              unassigned      YES unset  up                    down    
FastEthernet5              unassigned      YES unset  up                    down    
FastEthernet6              unassigned      YES unset  up                    down    
FastEthernet7              unassigned      YES unset  up                    down    
          
R-temlog#

FastEthernet1のリンク状況を見るとadministratively down downとあります。

この状態はインターフェースが閉じていて、shutdownが設定されていることになります。

 

では、FastEthernet1にIPアドレスを設定していきます。

まずは以下のコマンドでFastEthernet1の設定を確認します。

R-temlog#show running-config interface FastEthernet0   
Building configuration...

Current configuration : 81 bytes
!
interface FastEthernet1
 no ip address ←IPアドレスがありません
 shutdown ←shutdownが設定されている
 duplex auto
 speed auto
end

R-temlog#

 

以下コマンドでIPアドレスを設定します。

R-temlog#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R-temlog(config)#interface FastEthernet1
R-temlog(config-if)#ip address 192.168.20.1 255.255.255.0

これでIPアドレスを設定できました。

 

IPアドレスの入力を間違えたら、以下のコマンドで削除します。

R-temlog(config-if)#no ip address
R-temlog(config-if)#shutdown
R-temlog(config-if)#

 

インターフェイスの有効化

続いてshutdownだったインターフェースを以下no shutdownコマンドで有効化します。

R-temlog(config-if)#no shutdown 
R-temlog(config-if)# 
R-temlog(config-if)#end 
R-temlog#

 

改めてIPアドレスが設定され、インターフェースが有効化されているか確認します。

R-temlog#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
BRI0                       unassigned      YES NVRAM  administratively down down
BRI0:1                     unassigned      YES unset  administratively down down
BRI0:2                     unassigned      YES unset  administratively down down
FastEthernet0              unassigned      YES manual administratively down down
FastEthernet1              192.168.20.1    YES manual down                  down ←IPアドレスが設定され、down downとなりインターフェースが有効になっている
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
FastEthernet4              unassigned      YES unset  up                    down
FastEthernet5              unassigned      YES unset  up                    down
FastEthernet6              unassigned      YES unset  up                    down
FastEthernet7              unassigned      YES unset  up                    down

R-temlog#

down downとなっているのはインターフェースが有効化されていて、ケーブルの接続がない状態です。

ケーブル接続されるとup upになります。

  FastEthernet1              192.168.20.1    YES NVRAM  up                    up             

 

FastEthernet1の設定を確認します。

R-temlog#show running-config interface fastEthernet1   
Building configuration...

Current configuration : 95 bytes
!
interface FastEthernet1
 ip address 192.168.20.1 255.255.255.0 ←IPアドレスが設定されている
 duplex auto
 speed auto
end

R-temlog#

 

パスワードの設定

Ciscoルーターの管理アクセスを保護するパスワード設定を行います。

コンソールパスワード

コンソールポートに対するパスワードを設定していきます。

以下のようにラインコンフィグレーションモードでパスワード設定とパスワードチェックを有効にします。

R-temlog(config)#
R-temlog(config)#line console 0
R-temlog(config-line)#password cisco ←パスワードをciscoと設定する
R-temlog(config-line)#login ←ログイン時のパスワードチェックを有効にする
R-temlog(config-line)#

 

一度ログアウトをして、設定したパスワードでログインしてみます。

R-temlog#logout

!
<中途省略>
!

R-temlog con0 is now available

!
<中途省略>
!

Press RETURN to get started.

!
<中途省略>
!

User Access Verification

Password: ←表示はされませんが設定したciscoとコマンドを打ちます
R-temlog> ←ユーザーモードのプロンプトが表示

 

特権モードのパスワード

ユーザーモードから特権モードに移行する際のパスワード設定を行います。

ここでは暗号化なしのパスワード設定と暗号化ありのパスワード設定の両方を設定しますが、本来は暗号化ありのパスワードだけでOKです。あとで暗号化なしの設定は消去します。

グローバールコンフィグレーションモードで以下コマンドで設定。

R-temlog#configure terminal    
Enter configuration commands, one per line.  End with CNTL/Z.
R-temlog(config)#enable password cisco2 ←暗号化なしのパスワード設定
R-temlog(config)#enable secret cisco3 ←暗号化ありのパスワード設定
R-temlog(config)#exit
R-temlog#

 

show running-config | include enableコマンドで設定したパスワード確認してみます。

R-temlog#show running-config | include enable
enable secret 5 $1$9ckL$bC6yQ.7PyfmoC3cUqwUOe. ←暗号化されたパスワード
enable password cisco2 ←暗号化されていないパスワード
R-temlog#

 

では実際にユーザーモードから特権モードに移行してみます。

R-temlog#disable
R-temlog>enable
Password: ←暗号化されていないパスワードを入力
Password: ←暗号化されているパスワードを入力
R-temlog# ←特権モードに移行できました

 

コンフィグレーションファイルのパスワード暗号化

特権モードの暗号化ありのパスワード設定以外はデフォルトで暗号化されません。

ですのでshow running-configコマンドで今まで設定したコンソールパスワードと特権モードの暗号化ありのパスワードを確認すると丸見えになってしまします。

R-temlog#show running-config
Building configuration...

Current configuration : 1333 bytes
!
! Last configuration change at 04:29:27 UTC Sun Aug 11 2019
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption ←パスワード暗号化が無効
!
hostname R-temlog
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$JbwL$uVU4zeCbkdSMBLhMCu1e/1
enable password cisco2 ←特権モードの暗号化なしのパスワード
!
no aaa new-model
!
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip source-route
!         
!         
!         
!         
!         
ip cef    
no ipv6 cef
!         
multilink bundle-name authenticated
!         
!         
!         
license udi pid CISCO1812-J/K9 sn FHK100752MA
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown 
!         
interface FastEthernet0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet1
 ip address 192.168.20.1 255.255.255.0
 duplex auto
 speed auto
!         
interface FastEthernet2
 no ip address
!         
interface FastEthernet3
 no ip address
!         
interface FastEthernet4
 no ip address
!
interface FastEthernet5
 no ip address
!
interface FastEthernet6
 no ip address
!
interface FastEthernet7
 no ip address
!
interface FastEthernet8
 no ip address
!
interface FastEthernet9
 no ip address
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!         
!         
!         
!         
!         
!         
!         
!         
!         
control-plane
!         
!         
!         
line con 0
 password cisco ←コンソールパスワード
 login    
line aux 0
line vty 0 4
 login    
 transport input all
!         
end       
          
R-temlog#

 

以下のservice password-encryptionコマンドでコンフィグレーションファイルのテキストを暗号化します。

R-temlog#configure terminal 
R-temlog(config)#service password-encryption
R-temlog(config)#exit
R-temlog#

 

show running-configコマンドで暗号化されているかを確認します。

R-temlog#show running-config
Building configuration...

Current configuration : 1349 bytes
!
! Last configuration change at 04:38:53 UTC Sun Aug 11 2019
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption ←パスワード暗号化が有効
!
hostname R-temlog
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$JbwL$uVU4zeCbkdSMBLhMCu1e/1
enable password 7 104D000A061840 ←特権モードの暗号化なしのパスワードが暗号化された
!
no aaa new-model
!
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip source-route
!         
!         
!         
!         
!         
ip cef    
no ipv6 cef
!         
multilink bundle-name authenticated
!         
!         
!         
license udi pid CISCO1812-J/K9 sn FHK100752MA
!         
!         
!         
!         
!         
!         
!         
!         
!         
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown 
!         
interface FastEthernet0
 no ip address
 shutdown 
 duplex auto
 speed auto
!         
interface FastEthernet1
 ip address 192.168.20.1 255.255.255.0
 duplex auto
 speed auto
!         
interface FastEthernet2
 no ip address
!         
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 no ip address
!
interface FastEthernet5
 no ip address
!
interface FastEthernet6
 no ip address
!
interface FastEthernet7
 no ip address
!
interface FastEthernet8
 no ip address
!
interface FastEthernet9
 no ip address
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!         
control-plane
!         
!         
!         
line con 0
 password 7 045802150C2E ←コンソールパスワードが暗号化された
 login    
line aux 0
line vty 0 4
 login    
 transport input all
!         
end       
          
R-temlog#

 

enable passwordは消去します。

R-temlog#configure terminal
R-temlog(config)#no enable password
R-temlog(config)#exit
R-temlog#

 

設定の保存

最後にコンフィグレーションファイルを保存します。

今までの設定はrunning-configに反映していましたが、このままシステムの電源をOFFにすると設定が消えてしまいます。

電源をOFFにしても設定を保存しておくにはstartup-configに保持する必要があります。

以下コマンドでstartup-config

R-temlog#copy running-config startup-config         
Destination filename [startup-config]? ←Enter
Building configuration...
[OK]
R-temlog#

 

最後にコマンドをまとめました

最後にCiscoルーターの基本設定を一気に設定できるようにコマンドをまとめました。

Router>enable 
Router#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z. 
R-temlog(config)#interface FastEthernet1 
R-temlog(config-if)#ip address 192.168.20.1 255.255.255.0
R-temlog(config-if)#no shutdown
R-temlog(config-if)#exit
R-temlog(config)#line console 0 
R-temlog(config-line)#password cisco 
R-temlog(config-line)#login
R-temlog(config-line)#exit
R-temlog(config)#enable secret cisco3
R-temlog(config)#service password-encryption 
R-temlog(config)#exit 
R-temlog#copy running-config startup-config 
Destination filename [startup-config]? ←Enter 
Building configuration... 
[OK] 
R-temlog#

 

ネットワークを全く知識なしから学びたい方

 

より深く学びたい方

 

Ciscoルーターのコンソール接続から、Telnet接続まで以下で連載していますのでこちらもぜひご覧ください。

  1. Ciscoルーターへコンソール接続するためのケーブリングから初期起動まで 
  2. Ciscoルーターの基本設定|設定・確認コマンドから保存方法まで ←現在
  3. CiscoルーターへTelnet接続するまで

 

 

以上、テム(@temlog_net)でした。

ネットワーク
スポンサーリンク
テム

インフラエンジニアやっております。ネットワーク・サーバーのこと、使ってよかったサービス・買ってよかったモノなど幅広めで更新中。

テムをフォローする
テムをフォローする
TEMLOG -テムログ-

コメント

タイトルとURLをコピーしました